Archive: Registry Plugin Behaviour in 64bit PC

Registry Plugin Behaviour in 64bit PC
Hi there...

I am trying to find out whether a particular registry key exist or not with the macro ${registry::KeyExists}. I am checking for a 64bit application's regkey. Since It is 64bit application, Its regkey resided at "HKEY_LOCAL_MACHINE\SOFTWARE\[APPLICATION]".

But the registry plugin is looking for this at

Is there any way to check the 64bit regkey with registry plugin ? I tried to use "SetRegView 64" before calling the macro ${registry::KeyExists}., but still it is looking under Wow6432Node. any help please...

Are you using the most recent version? I'm pretty sure Instructor updated it to use SetRegView 64.


Oh...!!! I missed it to check the registry plugin version. I was just working on a PC which has older version of registry plugin. With just downloading and replacing the new version of registry., my problem solved and Its working now perfectly... :)

Thank you so much for your reply.. and I am sorry for not checking the version before posting here..!! Thank you.