Archive: Installer based on zip file not working!

Installer based on zip file not working!
Hello guys.

I downloaded and installed NSIS as I wanna create a setup for a simple app of mine.
But I kinda got a problem, int the NSIS start page (Menu) the "Installer based on ZIP file" option is grayed out.
Am I doing something wrong? Didn't I install the program correctly or what is the problem?
Can someone help me with this please?

Thanks in advance for any response.

P.S I'm new to this site and forum so if this the wrong place for the question feel free to move or remove it.

Try reinstalling NSIS as a full install, you probably disabed it.

Thank you for your answer but i tried reinstalling !

Well, the screenshot you showed is what you get if you install NSIS without the tools and the plugins. So I conclude that you didn't install the tools and the plugins. Are you sure you're running the nsis.exe from the proper directory? Perhaps you have two installations, one full and one partial? Check whether NSIS\Bin\zip2exe.exe exists.

Thanks, it worked when I tried a custom install and selected all features. But I don't understand why in the installation wizard there was an option saying full install and yet it didn't install all features.

THank you again for your help.